Arcade
Go Back   Anime Take Forums > AnimeTake > Support
Reload this Page How to change the default audio and subtitle settings on Media Player Classic?
Support Need help? Experiencing difficulties with anything technical or with AnimeTake? Then this is the place to ask.

Reply
 
LinkBack Thread Tools Display Modes
  (#1 (permalink)) Old
Dishonored
arilando newfag
 
Join Date: Apr 2012
Posts: 29
Rep Power: 8
Default How to change the default audio and subtitle settings on Media Player Classic? - 05-12-2012, 12:07 AM

So i'm having this minor problem that sometimes when i downloads an anime the default audio when i open the file is english, and i have to change the audio settings to japanese. However, this does't permenantly change the settings, if a close the video and open it again it will be english audio again and i would have to change the settings again. Is there anyway to make it so that when you open your video the default would be japanese audio with english subtile, so that you dont have to change the settings everytime you want to watch your video. This is on Media Player Classic.
Reply With Quote
  (#2 (permalink)) Old
Donor
Markus newfag
 
Markus's Avatar
 
Join Date: Dec 2009
Location: Probably in The Inferno
Posts: 76
Rep Power: 16
Default 05-12-2012, 01:29 AM

Ah yes, I've been having that annoying problem with Dual-Audio anime as well.
Sometimes it is so annoying that the "English" titled subtitles are actually in Japanese.

I think you have to change it through your codec instead of MPC-HC instead.


Click the image to open in full size.
Reply With Quote
  (#3 (permalink)) Old
Donor
gonzozoid Related to Mr. Good-guy
 
Join Date: Jan 2011
Location: ryozanpaku
Posts: 1,084
Rep Power: 13
Send a message via Yahoo to gonzozoid
Default 05-12-2012, 02:41 AM

You can switch audio by right-clicking on your codec icon.


Don't ask me for reup. I you want ost or jmusic before it even hit the shelves, you would have to find my website. just google for want you are looking for and add download at the end of your search. I can't post the name of my website, I have been banned 1 week already b/c I linked to it once. I won't be active in the forums anymore since it became a playground for wannabees.
Reply With Quote
  (#4 (permalink)) Old
Dishonored
heavensstrike newfag
 
Join Date: Jul 2010
Posts: 22
Rep Power: 14
Default 05-12-2012, 02:48 AM

If you're using CCCP:
1. Start menu -> Combined Community Codec Pack -> other filters -> Haali Media Splitter
2. Click on the "Options" tab, then expand the "Language" (click the "+" next to it)
3. Click on "Audio and Subtitle languages"
4. At the bottom for "Value:" type "jpn,eng".
5. Click "Apply" and "Ok" and you're done.
Reply With Quote
  (#5 (permalink)) Old
Dishonored
asiandj newfag
 
Join Date: Aug 2011
Posts: 21
Rep Power: 10
Default 05-12-2012, 06:08 AM

Quote:
Originally Posted by heavensstrike View Post
If you're using CCCP:
1. Start menu -> Combined Community Codec Pack -> other filters -> Haali Media Splitter
2. Click on the "Options" tab, then expand the "Language" (click the "+" next to it)
3. Click on "Audio and Subtitle languages"
4. At the bottom for "Value:" type "jpn,eng".
5. Click "Apply" and "Ok" and you're done.
The same works for Media Player Classic as well. As long as you have Haali Media Splitter installed.
Reply With Quote
  (#6 (permalink)) Old
Moderator
AlphaOmega Silent Helper
 
AlphaOmega's Avatar
 
Join Date: Jan 2009
Location: ┐( ̄ー ̄)┌
Posts: 1,628
Rep Power: 21
Send a message via MSN to AlphaOmega
Default 05-12-2012, 11:14 AM

Yeah, I have the same problem with this too.
I used heavensstrike's guide and it solved the issue, but on some the english are actually the japanese as Markus said earlier. So I tried to type in the "Value" ,"jpn,jpn" instead and it solved the problem but then the first issue came back. So any idea what to do?
Anyway, thanks heavensstrike for the solution.


Click the image to open in full size.
Kirisaki Chitoge <3
Reply With Quote
  (#7 (permalink)) Old
WsE WsE is offline
Adminifuckingstrator
WsE Related to Mr. Good-guy
 
WsE's Avatar
 
Join Date: May 2009
Location: Saa~
Posts: 3,301
Rep Power: 22
Default 05-12-2012, 11:34 AM

Remove the English audio from the files if you don't want to use it anyway?


[Only registered and activated users can see links. ]
Reply With Quote
  (#8 (permalink)) Old
Dishonored
arilando newfag
 
Join Date: Apr 2012
Posts: 29
Rep Power: 8
Default 05-12-2012, 12:24 PM

What is codec?
Reply With Quote
  (#9 (permalink)) Old
Dishonored
arilando newfag
 
Join Date: Apr 2012
Posts: 29
Rep Power: 8
Default 05-12-2012, 12:34 PM

Quote:
Originally Posted by heavensstrike View Post
If you're using CCCP:
1. Start menu -> Combined Community Codec Pack -> other filters -> Haali Media Splitter
2. Click on the "Options" tab, then expand the "Language" (click the "+" next to it)
3. Click on "Audio and Subtitle languages"
4. At the bottom for "Value:" type "jpn,eng".
5. Click "Apply" and "Ok" and you're done.
Do you mean during this in media player classic or in CCCP settings menu?
Reply With Quote
  (#10 (permalink)) Old
Dishonored
arilando newfag
 
Join Date: Apr 2012
Posts: 29
Rep Power: 8
Default 05-12-2012, 02:21 PM

Okay i understand it now, but the problem is, if i set it to jpn,eng, than the default is simply japanese audio with no subtitles, and if i set it to jpn,jpn than on some of my animes the default becomes japanese audio with english subtitles while on others it becomes english audio with no subtitles.

Last edited by arilando; 05-12-2012 at 02:24 PM..
Reply With Quote
  (#11 (permalink)) Old
Dishonored
heavensstrike newfag
 
Join Date: Jul 2010
Posts: 22
Rep Power: 14
Default 05-12-2012, 05:58 PM

arilando
You can also try setting the "Audio language priority" to "jpn" and the "subtitle language priority" to "eng".

What this does is that first the program will look for the combination in the "Audio and Subtitle languages", and if there's no match it'll use the individual value in the "Audio language priority" and "subtitle language priority".

AlphaOmega, if "jpn,jpn" worked, then the encoded must have labelled the english subtitle as "jpn" so it's the problem on the file's (or encoder's) end. Unless you want to rip the file apart and re-encode the whole thing with the change, there's not much you can do.

*note If there is 2 english subtitle in the file, the program will always use the first one. There's no way for it to choose the second one by itself so you'll have to change it manually everytime you watch.
Reply With Quote
  (#12 (permalink)) Old
Dragon Slayer
alcaray Related to Mr. Good-guy
 
alcaray's Avatar
 
Join Date: May 2010
Location: SoCal
Posts: 410
Rep Power: 15
Default 05-12-2012, 08:30 PM

1) The people who create the video files set a default to what audio and what subtitle track will load (if you haven't given your player instructions on how to override the defaults - see above).

2) The people who create the video files sometimes mislable things. Sometimes they call English Japanese and vice versa. Sometimes they do not lable the language of a track at all. There is nothing you can do to prevent this. Your player is not now and never will be smart enough to figure out if something is really Japanese or really English regardless of the labling. Just deal with it when it happens, is my advice.

If you have an abundance of energy, you can track down the maker of the file and let them know their error.


"There are people who make a life's work of tricking others... but just because something is convincing, that does not make it true. It is merely convincing."
- Karl Schroeder, Ventus
Reply With Quote
  (#13 (permalink)) Old
Dishonored
qwiqwi newfag
 
Join Date: May 2011
Posts: 1
Rep Power: 0
Default 05-22-2012, 06:21 AM

Quote:
Originally Posted by heavensstrike View Post
If you're using CCCP:
1. Start menu -> Combined Community Codec Pack -> other filters -> Haali Media Splitter
2. Click on the "Options" tab, then expand the "Language" (click the "+" next to it)
3. Click on "Audio and Subtitle languages"
4. At the bottom for "Value:" type "jpn,eng".
5. Click "Apply" and "Ok" and you're done.

Thanks a lot!!!! It finally solved the annoying english dub problem!
Reply With Quote
  (#14 (permalink)) Old
Dishonored
altus gravica newfag
 
Join Date: Jul 2012
Posts: 1
Rep Power: 0
Default 07-05-2012, 06:53 PM

Quote:
Originally Posted by heavensstrike View Post
If you're using CCCP:
1. Start menu -> Combined Community Codec Pack -> other filters -> Haali Media Splitter
2. Click on the "Options" tab, then expand the "Language" (click the "+" next to it)
3. Click on "Audio and Subtitle languages"
4. At the bottom for "Value:" type "jpn,eng".
5. Click "Apply" and "Ok" and you're done.
is there any other way?
because i don't using CCCP
Reply With Quote
  (#15 (permalink)) Old
Dishonored
Axmann8 newfag
 
Join Date: Jul 2012
Posts: 1
Rep Power: 0
Default 07-07-2012, 09:13 AM

It there a way to force MPC to play MKV files in the same language every time without using mkvmerge or just deleting the streams?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Forum Jump



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.